如何禁止WordPress版本、主题和插件的自动更新?

释放双眼,带上耳机,听听看~!

不管是 WordPress 版本还是插件或主题,都不可能百分百完美没问题,发现问题解决问题,然后这也是为什么会有后续版本出来的原因。有时候 WordPress 新版本会自动升级,或者 WordPress 插件/主题也会有新版本出来,这都没有问题,但是最怕的就是它们自动升级,有可能会覆盖我们自己 DIY 的代码功能,也可能会因为兼容问题导致站点崩溃,所以有些站长就想通过禁止 WordPress 版本、插件和主题的自动更新。目前有两个方法,一个是纯代码实现,另一个是安装插件实现。

方法一:在 wp-config.php 文件添加代码实现

WordPress 站点在根目录中都有一个配置文件 wp-config.php,我们可以通过在 wp-config.php 文件中添加以下代码行来禁用 WordPress 中的自动更新。

define( 'WP_AUTO_UPDATE_CORE', false );

以上代码将禁用 WordPress 所有的自动更新。如果你仅仅是想要禁止 WordPress 插件或 WordPress 主题的功能,那么可以通过在当前主题的 functions.php 文件中添加以下代码实现:

//禁用 WordPress 插件自动更新add_filter( 'auto_update_plugin', '__return_false' );//禁用 WordPress 主题自动更新add_filter( 'auto_update_theme', '__return_false' );

方法二:通过 Easy Updates Manager 插件实现

如何禁止WordPress版本、主题和插件的自动更新?2种方法 - 第1张 - boke112联盟(boke112.com)

前往 WordPress 官网下载Easy Updates Manager 插件并上传安装或直接在后台插件中在线安装并启用,然后点击后台的仪表盘 >> Updates Options(更新选项)即可进行具体的设置。

1、常规设置。这里我们可以进行统一设置,比如禁用所有的更新,或者针对 WordPress 版本、WordPress 插件、WordPress 主题、WordPress 翻译进行启用/禁用自动更新,手动更新和禁止更新等操作。

如何禁止WordPress版本、主题和插件的自动更新?2种方法 - 第2张 - boke112联盟(boke112.com)

2、插件选项。可以针对某一款 WordPress 插件进行操作,如允许或禁止该插件更新。

如何禁止WordPress版本、主题和插件的自动更新?2种方法 - 第3张 - boke112联盟(boke112.com)

3、主题选项。可以针对某款 WordPress 主题进行操作,如允许或禁止该主题更新。

如何禁止WordPress版本、主题和插件的自动更新?2种方法 - 第4张 - boke112联盟(boke112.com)

4、日志选项。这里可以清楚看到具体是从什么版本升级到什么版本,升级日期是哪天,如果发现因为某个插件或主题更新有问题,及时回滚到上一个版本就行。

如何禁止WordPress版本、主题和插件的自动更新?2种方法 - 第5张 - boke112联盟(boke112.com)

图片来自 Easy Updates Manager 插件

总结

大多数情况下 WordPress 插件和 WordPress 主题有新版本的时候都会有提示,但很少会出现自动更新的情况。WordPress 大版本更新,如 5.1 升级到 5.2 的时候也是有更新提示,不会自动更新。不过小版本更新如 5.2.1 到 5.2.2 正常情况下都会自动更新,这些更新一般都是修复安全性的问题。其实,不管是 WordPress 版本还是 WordPress 插件或 WordPress 主题,很多更新都是为了修复安全问题,所以老古建议大家有可能还是尽量及时升级为好。

人已赞赏
新零售/电商市场研究

揭秘“饭圈站姐”生意:50元买航班信息,蹲机场、蹭发布会年入百万

2020-11-27 13:56:43

新零售/电商市场研究

社区团购不是新故事,为啥巨头和小玩家都盯上了这生意?

2020-11-22 16:00:18

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索